ng_hole man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

NG_HOLE(4)		 BSD Kernel Interfaces Manual		    NG_HOLE(4)

NAME
     ng_hole — netgraph discard node type

SYNOPSIS
     #include <sys/types.h>
     #include <netgraph/ng_hole.h>

DESCRIPTION
     The hole node type silently discards all data and control messages it
     receives.	This type is used for testing and debugging.

HOOKS
     A ng_hole node accepts any request to connect, regardless of the hook
     name, as long as the name is unique.

CONTROL MESSAGES
     This node type supports the generic control messages, plus the following:

     NGM_HOLE_GET_STATS
	     This command takes an ASCII string argument, the hook name, and
	     returns the statistics associated with the hook as a struct
	     ng_hole_hookstat.

     NGM_HOLE_CLR_STATS
	     This command takes an ASCII string argument, the hook name, and
	     clears the statistics associated with the hook.

     NGM_HOLE_GETCLR_STATS
	     This command is identical to NGM_HOLE_GET_STATS, except that the
	     statistics are also atomically cleared.

SHUTDOWN
     This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
     when all hooks have been disconnected.

SEE ALSO
     netgraph(4), ng_echo(4), ngctl(8)

HISTORY
     The ng_hole node type was implemented in FreeBSD 4.0.

AUTHORS
     Julian Elischer ⟨julian@FreeBSD.org⟩

BSD				 May 19, 2004				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net