NG_RFC1490(4) BSD Kernel Interfaces Manual NG_RFC1490(4)NAMEng_rfc1490 — RFC 1490 netgraph node type
The rfc1490 node type performs protocol encapsulation, de-encapsulation,
and multiplexing according to RFC 1490 (which has since been updated by
RFC 2427). This particular type of encapsulation is often used on top of
frame relay DLCI channels.
The downstream hook is used to transmit and receive encapsulated frames.
On the other side of the node, the inet and ppp hooks are used to trans‐
mit and receive raw IP frames and PPP frames, respectively. PPP frames
are transmitted and received according to RFC 1973; in particular, frames
appearing on the ppp hook begin with the PPP protocol number. The
ethernet hook can be used to transmit and receive Ethernet frames (with‐
out a checksum) in RFC 1490's bridging format.
Typically the inet hook is connected to the inet hook of an ng_iface(4)
This node type supports the following hooks:
downstream Connects to the RFC 1490 peer entity.
ethernet Transmits and receives bridged raw Ethernet frames, without
inet Transmits and receives raw IP frames.
ppp Transmits and receives PPP frames.
This node type supports the generic control messages, plus the following:
This command sets encapsulation method for the node. The desired
method must be passed as a string message argument, and must be
one of the following supported encapsulation modes:
"ietf-ip" IP packets are sent using simple RFC1490/2427 encap‐
"ietf-snap" IP packets are sent inside SNAP frames. Also con‐
forms to RFC1490/2427.
"cisco" IP packets are sent and received using proprietary
Cisco encapsulation method.
This command returns current encapsulation method on the node.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
when all hooks have been disconnected.
SEE ALSOnetgraph(4), ng_frame_relay(4), ng_iface(4), ngctl(8)
C. Brown and A. Malis, Multiprotocol Interconnect over Frame Relay, RFC
W. Simpson, PPP in Frame Relay, RFC 1973.
The ng_rfc1490 node type was implemented in FreeBSD 4.0.
Julian Elischer ⟨julian@FreeBSD.org⟩
Not all of RFC 1490 is implemented.
BSD January 19, 1999 BSD