NMDM(4) BSD Kernel Interfaces Manual NMDM(4)NAMEnmdm — nullmodem terminal driver
The nmdm driver provides two tty(4) devices connected by a virtual “null
If either of the two tty devices have the CDSR_OFLOW bit (“stty dsrflow”)
set in their line discipline, the nmdm device will emulate the speed con‐
figured in the termios(4) settings. The speed emulation works indepen‐
dently in the two directions, controlled by the slower end's termios set‐
tings (c_ispeed, c_ospeed, CS5 ... CS8, CSTOPB and PARENB).
/dev/nmdmN[AB] nullmodem device nodes. Where the A node has a matching
The nmdm driver implements “on-demand device creation” so simply access‐
ing a given instance in /dev will create it.
SEE ALSOstty(1), termios(4), tty(4)HISTORY
The nmdm driver first appeared in FreeBSD 4.4.
BSD January 27, 2005 BSD