NSMB.CONF(5) BSD File Formats Manual NSMB.CONF(5)NAMEnsmb.conf — configuration file for SMB requests
The nsmb.conf file contains information about the computers, users, and
shares or mount points for the SMB network protocol.
The configuration hierarchy is made up of several sections, each section
containing a few or several lines of parameters and their assigned val‐
ues. Each of these sections must begin with a section name enclosed
within square brackets, similar to:
The end of each section is marked by either the start of a new section,
or by the abrupt ending of the file, commonly referred to as the EOF.
Each section may contain zero or more parameters such as:
where key represents a parameter name, and value would be the parameter's
The SMB library uses the following information for section names:
Possible keywords may include:
Keyword Section Comment
A B C D
addr - + - - IP or IPX address of SMB server
charsets - + + + local:remote charset pair
nbns + + - - address of NetBIOS name server (WINS)
nbscope + + - - NetBIOS scope
nbtimeout + + - - timeout for NetBIOS name servers
password - - + + plain text or simple encrypted password used to
access the given share
retry_count + + - - number of retries before connection is marked
timeout + + - - SMB request timeout
workgroup + + + + workgroup name
/etc/nsmb.conf The default remote mount-point configuration file.
~/nsmb.conf The user specific remote mount-point configuration file.
What follows is a sample configuration file which may, or may not match
# Configuration file for example.com
# The 'FSERVER' is an NT server.
# User specific data for FSERVER
All lines which begin with the ‘#’ character are comments and will not be
parsed. The “default” section describes the default workgroup or domain,
in this case “SALES”. The next section depicted here as “FSERVER”,
defines a server section and then assigns it a charset which is only
required when Cyrillic characters are not used. The hostname value,
“fserv.example.com”, is also assigned in this section. “FSERVER:USER”,
defines the user settings and is useful for saving the password used dur‐
ing a specific connection. The password may be plaintext or obfuscated
using simple encryption. The simple encrypted password starts with the
`$$1' symbols. Warning: the encryption function is very weak and
intended only to hide clear text passwords. If the use of simple encryp‐
tion is desired, the following command may be used on a password:
At the time of this writing, the IPX protocol remains unsupported.
Future FreeBSD releases are expected to support this.
SEE ALSOsmbutil(1), mount_smbfs(8)AUTHORS
This manual page was written by Sergey Osokin ⟨osa@FreeBSD.org⟩ and Tom
BSD October 19, 2010 BSD