NVE(4) BSD Kernel Interfaces Manual NVE(4)NAMEnve — NVIDIA nForce MCP Networking Adapter device driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The nve driver provides support for the NVIDIA nForce MCP and nForce2
MCP2 networking adapter that is embedded in the southbridge of most
nForce and nForce2 motherboards.
This driver is a reimplementation of the NVIDIA supported Linux nvnet
driver and uses the same closed source API library to access the underly‐
ing hardware. There is currently no programming documentation available
for this device, and therefore little is known about the internal archi‐
tecture of the MAC engine itself.
The nve driver supports the following media types:
autoselect Enable autoselection of the media type and options.
10baseT/UTP Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
1000baseTX Set 1000Mbps (Gigabit Ethernet) operation.
The nve driver supports the following media options:
full-duplex Set full duplex operation.
For more information on configuring this device, see ifconfig(8).
The nve driver supports the NVIDIA MCP onboard adapters of mainboards
with the following chipsets:
nve%d: couldn't map memory A fatal initialization error has occurred.
nve%d: couldn't map interrupt A fatal initialization error has occurred.
nve%d: failed to allocate memory There are not enough mbufs available
nve%d: device timeout The device has stopped responding to the network,
or there is a problem with the network connection (cable).
There are reports that when the card is in auto select mode, ifconfig
output reports a 10baseT/UTP output while the LEDs and bandwidth show
that the card is actually in 100baseTX mode.
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), ng_ether(4), rgephy(4),
The nve driver first appeared in FreeBSD 6.0.
The nve driver was written by Quinton Dolan ⟨firstname.lastname@example.org⟩ and David
E. O'Brien ⟨obrien@FreeBSD.org⟩.
BSD January 16, 2011 BSD