NXGE(4) BSD Kernel Interfaces Manual NXGE(4)NAMEnxge — Neterion Xframe 10GbE Server/Storage adapter driver
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The nxge driver provides support for Neterion Xframe-I and Xframe-II
adapters. The driver supports TCP Segmentation Offload (TSO/LSO), Large
Receive Offload (LRO), Jumbo Frames (5 buffer mode), Header Separation
(Rx 2 buffer mode), VLAN, and Promiscuous mode.
For general information and support, please visit the Neterion support
Support for Jumbo Frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility con‐
figures the adapter to transmit and receive Jumbo Frames. Xframe
adapters support Jumbo Frames up to 9600 bytes.
For Jumbo Frames, the driver will try to allocate physically contiguous
buffers. Failures to do so may degrade the performance. To resolve such
problems, please visit http://www.neterion.com where additional informa‐
tion and a kernel patch can be found.
For more information on configuring this device, see ifconfig(8).
The nxge driver supports Neterion Xframe 10 Gigabit Ethernet adapters
listed in http://www.neterion.com/how/pricing.html.
For troubleshooting tips and FAQs, please visit
For any issues please send an email to ⟨firstname.lastname@example.org⟩.
SEE ALSOarp(4), netintro(4), ifconfig(8)HISTORY
The nxge device driver first appeared in FreeBSD 7.0.
The nxge driver was written by Neterion ⟨email@example.com⟩.
BSD October 16, 2007 BSD