P_CANSEE(9) BSD Kernel Developer's Manual P_CANSEE(9)NAMEp_cansee — determine visibility of a process
p_cansee(struct thread *td, struct proc *p);
This function can be used to determine if a given process p is visible to
the thread td, where the notion of “visibility” may be read as “awareness
The function is implemented using cr_cansee(9), and the dependencies on
sysctl(8) variables documented in the cr_cansee(9) manual page apply.
The p_cansee() function returns 0 if the process denoted by p is visible
by thread td, or a non-zero error return value otherwise.
[ESRCH] Process p is not visible to thread td as determined by
[ESRCH] Thread td has been jailed and process p does not
belong to the same jail as td.
[ESRCH] The MAC subsystem denied visibility.
SEE ALSOjail(2), sysctl(8), cr_cansee(9), mac(9), p_candebug(9), prison_check(9)BSD November 19, 2006 BSD