PAM_ECHO(8) BSD System Manager's Manual PAM_ECHO(8)NAMEpam_echo — Echo PAM module
[service-name] module-type control-flag pam_echo [arguments]
The echo service module for PAM displays its arguments to the user, sepa‐
rated by spaces, using the current conversation function.
If the % character occurs anywhere in the arguments to pam_echo, it is
assumed to introduce one of the following escape sequences:
%H The name of the host on which the client runs (PAM_RHOST).
%s The current service name (PAM_SERVICE).
%t The name of the controlling tty (PAM_TTY).
%U The applicant's user name (PAM_RUSER).
%u The target account's user name (PAM_USER).
Any other two-character sequence beginning with % expands to the charac‐
ter following the % character.
SEE ALSOpam.conf(5), pam(8)AUTHORS
The pam_echo module and this manual page were developed for the FreeBSD
Project by ThinkSec AS and NAI Labs, the Security Research Division of
Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035
(“CBOSS”), as part of the DARPA CHATS research program.
BSD February 6, 2003 BSD