PAM_RADIUS(8) BSD System Manager's Manual PAM_RADIUS(8)NAMEpam_radius — RADIUS authentication PAM module
[service-name] module-type control-flag pam_radius [options]
The pam_radius module provides authentication services based upon the
RADIUS (Remote Authentication Dial In User Service) protocol for the PAM
(Pluggable Authentication Module) framework.
The pam_radius module accepts these optional parameters:
causes pam_radius to use a previously entered password
instead of prompting for a new one. If no password has been
entered then authentication fails.
causes pam_radius to use a previously entered password, if
one is available. If no password has been entered,
pam_radius prompts for one as usual.
echo_pass causes echoing to be left on if pam_radius prompts for a
specifies a non-standard location for the RADIUS client con‐
figuration file (normally located in /etc/radius.conf).
specifies a NAS identifier to send instead of the hostname.
specifies a user whose passwd(5) entry will be used as a tem‐
plate to create the session environment if the supplied user‐
name does not exist in local password database. The user
will be authenticated with the supplied username and pass‐
word, but his credentials to the system will be presented as
the ones for username, i.e., his login class, home directory,
resource limits, etc. will be set to ones defined for
If this option is omitted, and there is no username in the
system databases equal to the supplied one (as determined by
call to getpwnam(3)), the authentication will fail.
specifies a NAS IP address to be sent. If option is present,
but there is no value provided then IP address corresponding
to the current hostname will be used.
/etc/radius.conf The standard RADIUS client configuration file for
pam_radiusSEE ALSOpasswd(5), radius.conf(5), pam(8)HISTORY
The pam_radius module first appeared in FreeBSD 3.1. The pam_radius man‐
ual page first appeared in FreeBSD 3.3.
The pam_radius manual page was written by Andrzej Bialecki
The pam_radius module was written by John D. Polstra ⟨jdp@FreeBSD.org⟩.
BSD October 28, 2002 BSD