pcm man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

SOUND(4)		 BSD Kernel Interfaces Manual		      SOUND(4)

NAME
     sound, pcm, snd — DragonFly PCM audio device infrastructure

SYNOPSIS
     To compile this driver into the kernel, place the following line in your
     kernel configuration file:

	   device pcm

     For non-PnP sound cards:

	   device pcm0 at isa? port? irq 5 drq 1 flags 0x15

DESCRIPTION
     The sound driver provides support for PCM audio play and capture.	This
     driver also supports various PCI, ISA, WSS/MSS compatible sound cards,
     AC97 mixer and High Definition Audio.  Once the sound driver attaches,
     supported devices provide audio record and playback channels.  The
     DragonFly sound system provides dynamic mixing “VCHAN” and rate conver‐
     sion “soft formats”.  True full duplex operation is available on most
     sound cards.

     If the sound card is supported by a bridge driver, the sound driver works
     in conjunction with the bridge driver.

     Apart from the usual parameters, the flags field is used to specify the
     secondary DMA channel (generally used for capture in full duplex cards).
     Flags are set to 0 for cards not using a secondary DMA channel, or to
     0x10 + C to specify channel C.

     The driver does its best to recognize the installed hardware and drive it
     correctly so the user is not required to add specific settings to the
     kernel config file.  For PCI and ISA PnP cards this is actually easy
     since they identify themselves.  For legacy ISA cards, the driver looks
     for MSS cards at addresses 0x530 and 0x604 (unless overridden in the ker‐
     nel config file ) .

   Boot Variables
     In general, the module snd_foo corresponds to device snd_foo and can be
     loaded by the boot loader(8) via loader.conf(5) or from the command line
     using the kldload(8) utility.  Options which can be specified in
     /boot/loader.conf include:

	   snd_driver_load   (“NO”) If set to “YES”, this option loads all
			     available drivers.

	   snd_emu10k1_load  (“NO”) If set to “YES”, only the SoundBlaster 5.1
			     driver and dependent modules will be loaded.

	   snd_foo_load	     (“NO”) If set to “YES”, load driver for
			     card/chipset foo.

   VCHANs
     Each device can optionally support more playback channels than physical
     hardware provides by using “virtual channels” or VCHANs.  VCHAN options
     can be configured via the sysctl(8) interface but can only be manipulated
     while the device is inactive.

   Runtime Configuration
     The following sysctl(8) variables are available:

	   hw.snd.pcm%d.buffersize     Configure the amount of DMA bufferspace
				       available for a device.

	   hw.snd.targetirqrate	       Set the default block size such that
				       continuous playback will achieve this
				       IRQ rate.  This value can be tuned to
				       improve application performance.
				       Increase this value when the sound lags
				       and decrease it if sound stutters or
				       breaks up.

	   hw.snd.report_soft_formats  Controls the internal format conversion
				       if it is available transparently to the
				       application software.  When disabled or
				       not available, the application will
				       only be able to select formats the
				       device natively supports.

	   hw.snd.verbose	       Level of verbosity for the /dev/sndstat
				       device.	Higher values include more
				       output and the highest level, three,
				       should be used when reporting problems.
				       Other options include:

				       0   Installed devices and their allo‐
					   cated bus resources.

				       1   The number of playback, record,
					   virtual channels, and flags per
					   device.

				       2   Channel information per device
					   including the channel's current
					   format, speed, and pseudo device
					   statistics such as buffer overruns
					   and buffer underruns.

				       3   File names and versions of the cur‐
					   rently loaded sound modules.

	   hw.snd.maxautovchans	       Global VCHAN setting that only affects
				       devices with only one playback channel
				       available.  The sound system will
				       dynamically create up this many VCHANs.
				       Set to “0” if no VCHANS are desired.

	   hw.snd.pcm%d.vchans	       The current number of VCHANs allocated
				       per device.  This can be set to preal‐
				       locate a certain number of VCHANs.
				       Setting this value to “0” will disable
				       VCHANs for this device.

   Recording Channels
     On devices that have more than one recording source (ie: mic and line),
     there is a corresponding /dev/dspr%d.%d device.

   Statistics
     Channel statistics are only kept while the device is open.	 So with situ‐
     ations involving overruns and underruns, consider the output while the
     errant application is open and running.

   IOCTL Support
     The driver supports most of the OSS ioctl() functions, and most applica‐
     tions work unmodified.  A few differences exist, while memory mapped
     playback is supported natively and in Linux emulation, memory mapped
     recording is not due to VM system design.	As a consequence, some appli‐
     cations may need to be recompiled with a slightly modified audio module.
     See <sys/soundcard.h> for a complete list of the supported ioctl() func‐
     tions.

FILES
     The sound drivers may use the following device nodes:

     /dev/audio%d.%d  Sparc-compatible audio device.
     /dev/dsp%d.%d    Digitized voice device.
     /dev/dspW%d.%d   Like /dev/dsp, but 16 bits per sample.
     /dev/dspr%d.%d   Should be connected to a record codec.
     /dev/sndstat     Current sound status, including all channels and driv‐
		      ers.

     The first number in the device node represents the unit number of the
     sound device.  All sound devices are listed in /dev/sndstat.  Additional
     messages are sometimes recorded when the device is probed and attached,
     these messages can be viewed with the dmesg(8) utility.

DIAGNOSTICS
     ac97: dac not ready  AC97 codec is not likely to be accompanied with the
     sound card.

     unsupported subdevice XX  A device node is not created properly.

SEE ALSO
     snd_ad1816(4), snd_als4000(4), snd_atiixp(4), snd_cmi(4), snd_cs4281(4),
     snd_csa(4), snd_ds1(4), snd_emu10k1(4), snd_envy24(4), snd_envy24ht(4),
     snd_es137x(4), snd_ess(4), snd_fm801(4), snd_gusc(4), snd_hda(4),
     snd_ich(4), snd_maestro(4), snd_maestro3(4), snd_mss(4), snd_neomagic(4),
     snd_sbc(4), snd_solo(4), snd_spicds(4), snd_t4dwave(4), snd_uaudio(4),
     snd_via8233(4), snd_via82c686(4), snd_vibes(4), loader.conf(5), dmesg(8),
     kldload(8), sysctl(8)

     The OSS API, http://www.opensound.com/pguide/oss.pdf.

HISTORY
     The sound device driver first appeared in FreeBSD 2.2.6 as pcm, written
     by Luigi Rizzo.  It was later rewritten in FreeBSD 4.0 by Cameron Grant.
     The API evolved from the VOXWARE standard which later became OSS stan‐
     dard.

AUTHORS
     Luigi Rizzo ⟨luigi@iet.unipi.it⟩ initially wrote the pcm device driver
     and this manual page.  Cameron Grant ⟨gandalf@vilnya.demon.co.uk⟩ later
     revised the device driver for FreeBSD 4.0.	 Seigo Tanimura
     ⟨tanimura@r.dl.itc.u-tokyo.ac.jp⟩ revised this manual page.  It was then
     rewritten for FreeBSD 5.2.

BUGS
     Some features of your sound card (e.g., global volume control) might not
     be supported on all devices.

BSD			       November 26, 2006			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net