physio man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

PHYSIO(9)		 BSD Kernel Developer's Manual		     PHYSIO(9)

NAME
     physio — initiate I/O on raw devices

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     int
     physio(dev_t dev, struct uio *uio, int ioflag);

DESCRIPTION
     The physio() is a helper function typically called from character device
     read() and write() routines to start I/O on a user process buffer.	 The
     maximum amount of data to transfer with each call is determined by
     dev->si_iosize_max.  The physio() call converts the I/O request into a
     strategy() request and passes the new request to the driver's strategy()
     routine for processing.

     Since uio normally describes user space addresses, physio() needs to lock
     those pages into memory.  This is done by calling vmapbuf() for the
     appropriate pages.	 physio() always awaits the completion of the entire
     requested transfer before returning, unless an error condition is
     detected earlier.

     A break-down of the arguments follows:

     dev     The device number identifying the device to interact with.

     uio     The description of the entire transfer as requested by the user
	     process.  Currently, the results of passing a uio structure with
	     the uio_segflg set to anything other than UIO_USERSPACE are unde‐
	     fined.

     ioflag  The ioflag argument from the read() or write() function calling
	     physio().

RETURN VALUES
     If successful physio() returns 0.	EFAULT is returned if the address
     range described by uio is not accessible by the requesting process.
     physio() will return any error resulting from calls to the device strat‐
     egy routine, by examining the B_ERROR buffer flag and the b_error field.
     Note that the actual transfer size may be less than requested by uio if
     the device signals an “end of file” condition.

SEE ALSO
     read(2), write(2)

HISTORY
     The physio manual page is originally from NetBSD with minor changes for
     applicability with FreeBSD.

     The physio call has been completely re-written for providing higher I/O
     and paging performance.

BSD				 July 8, 2004				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net