PMAP_CHANGE_WIRING(9) BSD Kernel Developer's Manual PMAP_CHANGE_WIRING(9)NAMEpmap_change_wiring — change physical wiring for a map or virtual address
pmap_change_wiring(pmap_t pmap, vm_offset_t va, boolean_t wired);
The pmap_change_wiring() function changes the wiring attribute for the
page at virtual address va in the physical map pmap. A wired page gets
its name from being “wired” into the system page tables so that it will
not be paged out.
The mapping must already exist in the pmap. If wired is TRUE, the map's
wired page count will be incremented; if FALSE, it will be decremented.
It is typically called by the vm_fault_unwire() function.
This manual page was written by Bruce M Simpson ⟨firstname.lastname@example.org⟩.
BSD July 21, 2003 BSD