PMAP_MAP(9) BSD Kernel Developer's Manual PMAP_MAP(9)NAMEpmap_map — map a physical memory range into kernel virtual address (KVA)
pmap_map(vm_offset_t *virt, vm_paddr_t start, vm_paddr_t end, int prot);
The pmap_map() function maps a range of physical addresses into kernel
virtual address (KVA) space, from start to end, with protection bits
The value passed in *virt is treated as a hint for the virtual address of
the beginning of the mapping.
The prot argument is currently ignored by machine-dependent implementa‐
Architectures which can support a direct mapped physical to virtual
region can return the appropriate address within that region, leaving
The pmap_map() function returns the virtual address of the beginning of
the mapping, if the mapping was successfully made; *virt will also be
updated with the first usable address after the mapped region.
If the function is unsuccessful, NULL is returned.
This manual page was written by Bruce M Simpson ⟨firstname.lastname@example.org⟩.
BSD July 21, 2003 BSD