pmatch man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

PMATCH(9)		 BSD Kernel Developer's Manual		     PMATCH(9)

NAME
     pmatch — performs pattern matching on strings

SYNOPSIS
     #include <sys/systm.h>

     int
     pmatch(const char *string, const char *pattern, const char **estr);

DESCRIPTION
     Extract substring matching pattern from string.  If not NULL, estr points
     to the end of the longest exact or substring match.

     pmatch() uses the following metacharacters:

     ?	     match any single character.

     *	     match any character 0 or more times.

     [	     define a range of characters that will match.  The range is
	     defined by 2 characters separated by a ‘-’.  The range definition
	     has to end with a ‘]’.  A ‘^’ following the ‘[’ will negate the
	     range.

RETURN VALUES
     pmatch() will return 2 for an exact match, 1 for a substring match, 0 for
     no match and -1 if an error occurs.

BSD			       October 12, 2003				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net