PORTMAP(8) BSD System Manager's Manual PORTMAP(8)NAMEportmap — DARPA port to RPC program number mapper
Portmap is a server that converts RPC program numbers into DARPA protocol
port numbers. It must be running in order to make RPC calls.
When an RPC server is started, it will tell portmap what port number it
is listening to, and what RPC program numbers it is prepared to serve.
When a client wishes to make an RPC call to a given program number, it
will first contact portmap on the server machine to determine the port
number where RPC packets should be sent.
Portmap must be started before any RPC servers are invoked.
Normally portmap forks and dissociates itself from the terminal like any
other daemon. Portmap then logs errors using syslog(3).
-d (debug) prevents portmap from running as a daemon, and causes
errors and debugging information to be printed to the standard
SEE ALSOinetd.conf(5), rpcinfo(8), inetd(8)BUGS
If portmap crashes, all servers must be restarted.
The portmap command appeared in 4.3BSD
4.3 Berkeley Distribution June 6, 1993 4.3 Berkeley Distribution