POWERD(8) BSD System Manager's Manual POWERD(8)NAMEpowerd — system power control utility
SYNOPSISpowerd [-a mode] [-b mode] [-i percent] [-m freq] [-M freq] [-n mode]
[-p ival] [-P pidfile] [-r percent] [-v]
The powerd utility monitors the system state and sets various power con‐
trol options accordingly. It offers four modes (maximum, minimum, adap‐
tive and hiadaptive) that can be individually selected while on AC power
or batteries. The modes maximum, minimum, adaptive and hiadaptive may be
abbreviated max, min, adp, hadp.
Maximum mode chooses the highest performance values. Minimum mode
selects the lowest performance values to get the most power savings.
Adaptive mode attempts to strike a balance by degrading performance when
the system appears idle and increasing it when the system is busy. It
offers a good balance between a small performance loss for greatly
increased power savings. Hiadaptive mode is like adaptive mode, but
tuned for systems where performance and interactivity are more important
than power consumption. It increases frequency faster, reduces the fre‐
quency less aggressively and will maintain full frequency for longer.
The default mode is adaptive for battery power and hiadaptive for the
The powerd utility recognizes the following runtime options:
-a mode Selects the mode to use while on AC power.
-b mode Selects the mode to use while on battery power.
-i percent Specifies the CPU load percent level when adaptive mode
should begin to degrade performance to save power. The
default is 50% or lower.
-m freq Specifies the minimum frequency to throttle down to.
-M freq Specifies the maximum frequency to throttle up to.
-n mode Selects the mode to use normally when the AC line state is
-p ival Specifies a different polling interval (in milliseconds) for
AC line state and system idle levels. The default is 250 ms.
-P pidfile Specifies an alternative file in which the process ID should
be stored. The default is /var/run/powerd.pid.
-r percent Specifies the CPU load percent level where adaptive mode
should consider the CPU running and increase performance.
The default is 75% or higher.
-v Verbose mode. Messages about power changes will be printed
to stdout and powerd will operate in the foreground.
SEE ALSOacpi(4), apm(4), cpufreq(4)HISTORY
The powerd utility first appeared in FreeBSD 6.0.
Colin Percival first wrote estctrl, the utility that powerd is based on.
Nate Lawson then updated it for cpufreq(4), added features, and wrote
this manual page.
The powerd utility should also power down idle disks and other components
besides the CPU.
If powerd is used with power_profile, they may override each other.
The powerd utility should probably use the devctl(4) interface instead of
polling for AC line state.
BSD December 21, 2009 BSD