preempt man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

PREEMPT(9)		 BSD Kernel Developer's Manual		    PREEMPT(9)

NAME
     preempt, yield — general preempt and yield functions

SYNOPSIS
     #include <sys/sched.h>

     void
     preempt(void);

     #include <sys/proc.h>

     void
     yield(void);

DESCRIPTION
     The preempt() function puts the current LWP back on the system run queue
     and performs an involuntary context switch.  The yield() function is
     mostly same as preempt(), except that it performs a voluntary context
     switch.

     These functions drop the kernel lock before switching and re-acquire it
     before returning.

BSD				 July 3, 2007				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net