PTY(4) BSD Kernel Interfaces Manual PTY(4)NAMEpty — BSD-style compatibility pseudo-terminal driver
The pty driver provides support for the traditional BSD naming scheme
that was used for accessing pseudo-terminals. When the device /dev/ptyXX
is being opened, a new terminal shall be created with the pts(4) driver.
A device node for this terminal shall be created, which has the name
New code should not try to allocate pseudo-terminals using this inter‐
face. It is only provided for compatibility with older C libraries that
tried to open such devices when posix_openpt(2) was being called.
The BSD-style compatibility pseudo-terminal driver uses the following
/dev/pty[l-sL-S][0-9a-v] Pseudo-terminal master devices.
/dev/tty[l-sL-S][0-9a-v] Pseudo-terminal slave devices.
SEE ALSOposix_openpt(2), pts(4), tty(4)HISTORY
A pseudo-terminal driver appeared in 4.2BSD.
Unlike previous implementations, the master slave device nodes are
destroyed when the PTY becomes unused. A call to stat(2) on a nonexis‐
tent master device will already cause a new master device node to be cre‐
ated. The master device can only be destroyed by opening and closing it.
The pty driver cannot be unloaded, because it cannot determine if it is
BSD August 20, 2008 BSD