rmsf(1M)rmsf(1M)NAMErmsf - remove a special (device) file
directory] special_file ...
class | driver] directory] hw_path
The command removes one or more special files from the directory and
potentially removes information about the associated device or devices
with H/W type or a (see ioscan(1M)) from the system.
If no options are specified, removes only the special_file specified on
the command line. The option causes to remove the definition of the
device from the system without removing any special files. The option
causes to remove the device definition and all special files that map
to it from the directory (or the directory specified with the option).
When the specified special_file or hw_path belongs to a persistent
device type, the device corresponding to special_file or hw_path should
not be in an open state in order for the command to complete success‐
When the option is used along with a persistent device type spe‐
cial_file or LUN hw_path, the command executes and displays Critical
Resource Analysis (CRA) on the corresponding device before removing the
special_file or hw_path. Other than with persistent device type spe‐
cial_file or LUN hw_path, the option will be ignored by the command for
any other type of special_file or hw_path. Use of the (quiet) option
along with suppresses the display of Critical Resource Analysis (CRA)
Without the option, if special_file is specified with a relative path,
the path is treated relative to the default device directory If spe‐
cial_file is specified with an absolute path and the option is also
used, the special_file with absolute path will have precedence over the
Note that if special_file belongs to a node for which H/W type is not
the device definition will not be removed from the system and the spe‐
cial_file will be removed if it is a leaf node.
If a is specified, special files are removed as follows:
· If hw_path belongs to a node with H/W type all special files
mapping to devices at that hardware path and the system defi‐
nition of those devices are removed. If the hw_path belongs
to LUN hardware path of a node of type the device should not
be in an open state for the command to complete successfully.
· If hw_path belongs to a node with H/W type all legacy special
files mapping to devices at that hardware path, as well as
the system definition of those devices, are removed.
· If hw_path belongs to a node for which H/W type is no special
files are removed; only corresponding node is removed.
· If hw_path belongs to a node for which H/W type is not any of
the above mentioned types, then a special file is removed as
· If it is a leaf node, only special files for that node
will be removed.
· If the node has children, then a warning message will be
issued and system definition of all the children devices
and their special files are removed.
The and options remove only those special files that are associated
with the given device driver or that belong to the given device class,
respectively. This is useful when there is more than one type of spe‐
cial file mapped to a single hardware path. These options are not sup‐
ported with the class or device drivers which do not have a hardware
module on the system; for example, the class.
If the option is specified, the definition of all devices at that hard‐
ware path are removed from the system, again without removing any spe‐
The (verbose) option displays the name of each special file as it is
deleted. The (quiet) option suppresses the deletion message.
With the option, disables the legacy naming model, removing all legacy
I/O nodes and their device special files from the system.
If the and options are specified, performs an unbind on the driver
associated with the given hw_path. The hw_path must be a LUN hardware
path (see intro(7)).
The option removes stale device special files and the stale IO nodes
from the system. A specific stale hw_path can be specified with If the
given node has children, all the children devices will be removed. Note
that when is used, no special files will be removed. Stale device spe‐
cial files can be displayed using the command with option (see
Note that most drivers do not support the ability to be removed from
If the device being removed from the system uses a dynamically assigned
major number, that number will be freed up for future allocation only
when used with option.
recognizes the following options:
Remove the definition of the device from the system
along with all special files that refer to the
device. This option cannot be used with
Initiates and displays the Critical Resource Analysis (CRA)
The (quiet) option can be used to suppress the
CRA report. Also note that this option cannot be
used in single user mode.
Match devices that belong to a given device class,
class. Device classes can be listed with the
command (see lsdev(1M)). This option cannot be
Match devices that are controlled by the specified device
driver. Device drivers can be listed with the
command (see lsdev(1M)). This option cannot be
Override the default device installation directory
and remove the special files from directory
instead. directory must exist; otherwise, dis‐
plays an error message and exits. See
Match devices at a given hardware path,
hw-path. Hardware paths can be listed with the
command (see ioscan(1M)).
A hardware path specifies the addresses of the
hardware components leading to a device. It con‐
sists of a string of numbers separated by periods
such as (a card), (a target address), and (a
If a hardware component is a bus converter, the
following period, if any, is replaced by a slash
as in and In the agile view (see intro(7)), the
devices will have new hardware path formats,
which can be displayed with the command (see
See section for more about using this option for
Remove the definition of the device from the system,
but not any special files. This option cannot be
Disable legacy naming model.
This command removes all legacy I/O nodes and
their device special files. Also this command
removes legacy stale device special files found
in the following directories:
Therefore, before running this command, all
applications should have been migrated to use the
agile naming model.
The command (see iofind(1M)) can be used to find
all the ASCII files on the system containing
legacy device file names or hardware paths.
The command will not complete successfully if any
legacy I/O nodes are in the open state. If this
is the case, the command will fail and it will
return information about the processes that
opened the legacy I/O nodes, such as process
name, PID, and device special file.
Note: If the legacy naming model needs to be re-
enabled, run (see insf(1M)). To check the cur‐
rent status of the legacy naming model, run
Before running this command, check the latest
release notes of HP-UX 11i Version 3 on for
information on limitations that exist when legacy
mode is disabled and how this may impact your
system. This command will not validate the pres‐
ence or utilization of products with these limi‐
tations. Also note that this option cannot be
used in single user mode.
Remove the dynamically assigned major number of the device.
This option must be used with the or or option.
Quiet option. Normally displays a message as each driver is
removed. This option suppresses the driver mes‐
sage, but not error messages.
Unbind the driver associated with the given hardware
path. The hardware path must be a LUN hardware
path. This option must be used with the option.
Prints the name of the special file as it is
removed by May be used as a progress indicator.
Remove all the stale IO nodes and the stale device special files
the system. These entries correspond to those
nodes which have an entry in the system I/O con‐
figuration files but the corresponding device is
not found (see ioconfig(4)).
This option removes the stale device special
files in the following directories only:
Also this option removes stale device special
files of interface drivers like and from the
directory. Note that when is used along with no
stale device special files will be removed.
exits with one of the following values:
Successful completion, including warning diagnostics.
An error occurred.
Driver does not support this feature.
Most of the diagnostic messages from are self-explanatory. Listed
below are some messages deserving further clarification. Errors cause
to halt immediately. Warnings allow the program to continue.
No device in the system matched the options specified.
Use to list the devices in the system (see ioscan(1M)).
The file is not associated with an IO device.
The H/W type of the node specified by
hw_path is BUS_NEXUS/INTERFACE. All the devices under this path
will be removed.
The definition of the device located at
hw_path and controlled by driver cannot be removed from the ker‐
nel. That is driver does not support the function.
The special file does not map to a device in the system;
the file is removed unless the option was specified.
Remove the special file from the current directory:
Remove the system definition of the device associated with along with
all special files that refer to the device:
Remove the system definitions for all devices associated with hardware
Remove all the stale IO nodes and stale device special files from the
Unbind a driver associated with a node corresponding to the hardware
Most commands and subsystems assume their device files are in therefore
the use of the option is discouraged.
Most device drivers do not support the unbind operation necessary to
remove the device from the system.
Use of the command should be done carefully when it is initiated on a
node with H/W type which maps to boot device or a node with H/W type to
which boot device is connected as this could lead to a system hang if
no mirroring Volume Group exists to the critical device.
was developed by HP.
rm(1), insf(1M), iofind(1M), ioscan(1M),
lsdev(1M), lssf(1M), mksf(1M), ioconfig(4),