RPC.LOCKD(8) BSD System Manager's Manual RPC.LOCKD(8)NAMErpc.lockd — NFS file locking daemon
SYNOPSISrpc.lockd [-d debug_level] [-g grace period]
The rpc.lockd utility provides monitored and unmonitored file and record
locking services in an NFS environment. To monitor the status of hosts
requesting locks, the locking daemon typically operates in conjunction
Options and operands available for rpc.lockd:
-d The -d option causes debugging information to be written to sys‐
log, recording all RPC transactions to the daemon. These mes‐
sages are logged with level LOG_DEBUG and facility LOG_DAEMON.
Specifying a debug_level of 1 results in the generation of one
log line per protocol operation. Higher debug levels can be
specified, causing display of operation arguments and internal
operations of the daemon.
-g The -g option allow to specify the grace period, in seconds.
During the grace period rpc.lockd only accepts requests from
hosts which are reinitialising locks which existed before the
server restart. Default is 30 seconds.
-w The -w option tells rpc.lockd to wait until the first client
locking request is made before starting the locking daemon(s).
This may be used on NFS clients to defer starting the NFS locking
daemons until it is known that they will be needed. (Note:
rpc.statd(8) will also be started if it isn't already running)
Error conditions are logged to syslog, irrespective of the debug level,
using log level LOG_ERR and facility LOG_DAEMON.
The rpc.lockd utility must NOT be invoked by inetd(8) because the proto‐
col assumes that the daemon will run from system start time. Instead, it
should be configured in rc.conf(5) to run at system startup.
/usr/include/rpcsvc/nlm_prot.x RPC protocol specification for the net‐
work lock manager protocol.
SEE ALSOsyslog(3), rc.conf(5), rpc.statd(8)BUGS
The current implementation serialises locks requests that could be
The implementation is based on the specification in "Protocols for X/Open
PC Interworking: XNFS, Issue 4", X/Open CAE Specification C218, ISBN 1
872630 66 9.
A version of rpc.lockd appeared in SunOS 4.
BSD September 24, 1995 BSD