RXFORMAT(8) BSD System Manager's Manual RXFORMAT(8)NAMErxformat — format floppy disks
SYNOPSISrxformat [-d] special
The rxformat program formats a diskette in the specified drive associated
with the special device special. (Special is normally /dev/rx0, for
drive 0, or /dev/rx1, for drive 1.)
-d Force double density formatting. By default, the diskette is
formatted single density; Single density is compatible with the
IBM 3740 standard (128 bytes/sector). In double density, each
sector contains 256 bytes of data.
Before formatting a diskette rxformat prompts for verification if stan‐
dard input is a tty (this allows a user to cleanly abort the operation;
note that formatting a diskette will destroy any existing data). Format‐
ting is done by the hardware. All sectors are zero-filled.
No such device
means that the drive is not ready, usually because no disk is in
the drive or the drive door is open. Other error messages are
A floppy may not be formatted if the header info on sector 1, track 0 has
been damaged. Hence, it is not possible to format a completely degaussed
disk. (This is actually a problem in the DEC hardware.)
The rxformat command appeared in 4.2BSD.
4.2 Berkeley Distribution March 16, 1991 4.2 Berkeley Distribution