SDPCONTROL(8) BSD System Manager's Manual SDPCONTROL(8)NAMEsdpcontrol — SDP query utility
sdpcontrol-a address command [parameters ...]
sdpcontrol-l [-c path] command [parameters ...]
The sdpcontrol utility attempts to query the specified Service Discovery
Protocol (SDP) server. Remote SDP servers are identified by their
address. Connection to the local SDP server is made via the control
socket. The sdpcontrol utility uses Service Search Attribute Requests
and prints results to standard output and error messages to standard
The options are as follows:
Connect to the remote device with the specified address. The
address can be specified as BD_ADDR or a name. If a name was
specified, the sdpcontrol utility attempts to resolve the name
Specify path to the control socket. The default path is
-h Display usage message and exit.
-l Query the local SDP server via the control socket.
One of the supported commands (see below). The special command
help can be used to obtain a list of all supported commands. To
get more information about a specific command, use help command.
One or more optional space separated command parameters.
The currently supported node commands in sdpcontrol are:
The sdpcontrol utility only implements client side functionality.
The sdpcontrol utility only requests the following attributes from the
1. Service Record Handle
2. Service Class ID List
3. Protocol Descriptor List
4. Bluetooth Profile Descriptor List
The sdpcontrol utility exits 0 on success, and >0 if an error occurs.
SEE ALSObluetooth(3), sdp(3)AUTHORS
Maksim Yevmenkin ⟨firstname.lastname@example.org⟩
BSD September 7, 2003 BSD