SERVICES_MKDB(8) BSD System Manager's Manual SERVICES_MKDB(8)NAMEservices_mkdb — generate the services databases
SYNOPSISservices_mkdb [-q] [-o database] [file]
DESCRIPTIONservices_mkdb creates a db(3) database for the specified file. If no
file is specified, then /etc/services is used. The database is installed
into /var/db/services.db. The file must be in the correct format (see
The options are as follows:
Put the output databases in the named file.
-q Don't warn about duplicate services.
-u Print the services file to stdout, omitting duplicate entries and
The databases are used by the C library services routines (see
services_mkdb exits zero on success, non-zero on failure.
/var/db/services.db The current services database.
/var/db/services.db.tmp A temporary file.
/etc/services The current services file.
SEE ALSOdb(3), getservent(3), services(5)BUGS
Because services_mkdb guarantees not to install a partial destination
file it must build a temporary file in the same file system and if suc‐
cessful use rename(2) to install over the destination file.
If services_mkdb fails it will leave the previous version of the destina‐
tion file intact.
BSD April 4, 2010 BSD