SES(4) OpenBSD Programmer's Manual SES(4)NAMEses - SCSI Enclosure Services
ses* at scsibus?
The ses driver provides support for monitoring the various environmental
sensors present in SCSI enclosures using the SCSI Enclosure Services
command set. The hardware monitoring is accessed via the hw.sensors
SCSI devices have a fairly high level interface to the system and talk to
it via a SCSI host adapter (e.g. ahc(4)). A SCSI adapter must also be
separately configured into the system before a SCSI enclosure can be
When the SCSI adapter is probed during boot, the SCSI bus is scanned for
devices. Any SCSI-2 devices of type ``Enclosure service'' or SCSI-3
devices of type ``Processor'' will be attached to the ses driver.
SES compliant devices can provide an arbitrary set of sensors which may
include the following types:
Sensor Units Typical Use
temp uK temperature
fan RPM fan
psu On/Off power supply
doorlock On/Off door lock
alarm On/Off enclosure alarm
Sensor data is updated every 10 seconds.
An enclosure may provide environmental information using an alternative
command set to the SCSI Enclosure Services used by this driver.
Enclosures using the SCSI Accessed Fault-Tolerant Enclosure command set
may be monitored by the safte(4) driver.
SEE ALSOintro(4), safte(4), scsibus(4), sensorsd(8), sysctl(8)HISTORY
The ses driver first appeared in OpenBSD 3.8.
The ses driver was written by David Gwynne <email@example.com>.
OpenBSD 4.9 March 22, 2010 OpenBSD 4.9