SGE(4) BSD Kernel Interfaces Manual SGE(4)NAMEsge — Silicon Integrated Systems SiS190/191 Fast/Gigabit Ethernet driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The sge device driver provides support for SiS190 Fast Ethernet con‐
trollers and SiS191 Fast/Gigabit Ethernet controllers.
All LOMs supported by the sge driver have TCP/UDP/IP checksum offload for
transmit and receive, TCP segmentation offload (TSO), hardware VLAN tag
stripping/insertion features. Due to lack of documentation Wake On Lan
(WOL), Jumbo frame and an interrupt moderation mechanism are not sup‐
The sge driver supports the following media types:
autoselect Enable autoselection of the media type and options. The
user can manually override the autoselected mode by adding
media options to rc.conf(5).
10baseT/UTP Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
1000baseTX Set 1000baseTX operation over twisted pair.
The sge driver supports the following media options:
full-duplex Force full duplex operation.
half-duplex Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
The sge device driver provides support for the following Ethernet con‐
· SiS190 Fast Ethernet controller
· SiS191 Fast/Gigabit Ethernet controller
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), ng_ether(4), rgephy(4), vlan(4),
The sge driver was written by Alexander Pohoyda
⟨email@example.com⟩. And enhanced by Nikolay Denev
⟨firstname.lastname@example.org⟩. It first appeared in FreeBSD 8.1.
BSD January 16, 2011 BSD