SND_ATIIXP(4) BSD Kernel Interfaces Manual SND_ATIIXP(4)NAMEsnd_atiixp — ATI IXP bridge device driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The snd_atiixp bridge driver allows the generic audio driver, sound(4),
to attach to ATI IXP audio devices. This driver supports 16bit playback
and recording, and 32bit native playback and recording.
The following sysctl(8) variables are available in addition to those
available to all sound(4) devices:
dev.pcm.%d.polling Experimental polling mode, where the driver
operates by querying the device state on each
tick using callout(9). Polling is disabled by
default. Do not enable it unless you are fac‐
ing weird interrupt problems or if the device
cannot generate interrupts at all.
The snd_atiixp driver supports the following audio chipsets:
· ATI IXP 200
· ATI IXP 300
· ATI IXP 400
The snd_atiixp device driver first appeared in FreeBSD 6.1.
This manual page was written by Joel Dahl ⟨joel@FreeBSD.org⟩.
The snd_atiixp driver does not support S/PDIF, but implementing it should
be fairly easy if the right hardware is available.
32bit native recording is broken on some hardware.
BSD November 29, 2006 BSD