src.conf man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

SRC.CONF(5)		    BSD File Formats Manual		   SRC.CONF(5)

NAME
     src.conf — source build options

DESCRIPTION
     The src.conf file contains settings that will apply to every build
     involving the FreeBSD source tree; see build(7).

     The src.conf file uses the standard makefile syntax.  However, src.conf
     should not specify any dependencies to make(1).  Instead, src.conf is to
     set make(1) variables that control the aspects of how the system builds.

     The default location of src.conf is /etc/src.conf, though an alternative
     location can be specified in the make(1) variable SRCCONF.	 Overriding
     the location of src.conf may be necessary if the system-wide settings are
     not suitable for a particular build.  For instance, setting SRCCONF to
     /dev/null effectively resets all build controls to their defaults.

     The only purpose of src.conf is to control the compilation of the FreeBSD
     source code, which is usually located in /usr/src.	 As a rule, the system
     administrator creates src.conf when the values of certain control vari‐
     ables need to be changed from their defaults.

     In addition, control variables can be specified for a particular build
     via the -D option of make(1) or in its environment; see environ(7).

     The values of variables are ignored regardless of their setting; even if
     they would be set to “FALSE” or “NO”.  Just the existence of an option
     will cause it to be honoured by make(1).

     The following list provides a name and short description for variables
     that can be used for source builds.

     WITHOUT_ACCT
	     Set to not build process accounting tools such as ac(8) and
	     accton(8).

     WITHOUT_ACPI
	     Set to not build acpiconf(8), acpidump(8) and related programs.

     WITHOUT_AMD
	     Set to not build amd(8), and related programs.

     WITHOUT_APM
	     Set to not build apm(8), apmd(8) and related programs.

     WITHOUT_ASSERT_DEBUG
	     Set to compile programs and libraries without the assert(3)
	     checks.

     WITHOUT_AT
	     Set to not build at(1) and related utilities.

     WITHOUT_ATM
	     Set to not build programs and libraries related to ATM network‐
	     ing.

     WITHOUT_AUDIT
	     Set to not build audit support into system programs.

     WITHOUT_AUTHPF
	     Set to not build authpf(8).

     WITHOUT_BIND
	     Setting this variable will prevent any part of BIND from being
	     built.  When set, it also enforces the following options:

	     WITHOUT_BIND_DNSSEC
	     WITHOUT_BIND_ETC
	     WITHOUT_BIND_LIBS_LWRES
	     WITHOUT_BIND_MTREE
	     WITHOUT_BIND_NAMED
	     WITHOUT_BIND_UTILS

     WITHOUT_BIND_DNSSEC
	     Set to avoid building or installing the DNSSEC related binaries,
	     dnssec-keygen(8) and dnssec-signzone(8).

     WITHOUT_BIND_ETC
	     Set to avoid installing the default files to
	     /var/named/etc/namedb.

     WITH_BIND_IDN
	     Set to enable IDN support for dig, host, and nslookup.  This
	     requires ports/dns/idnkit to be installed in /usr/local.

     WITH_BIND_LARGE_FILE
	     Set to enable 64-bit file support.

     WITH_BIND_LIBS
	     Set to install BIND libraries and include files.

     WITHOUT_BIND_LIBS_LWRES
	     Set to avoid installing the lightweight resolver library in
	     /usr/lib.

     WITHOUT_BIND_MTREE
	     Set to avoid running mtree(8) to create the chroot directory
	     structure under /var/named, and avoid creating an /etc/namedb
	     symlink to the chroot directory.  When set, it also enforces the
	     following options:

	     WITHOUT_BIND_ETC

     WITHOUT_BIND_NAMED
	     Set to avoid building or installing named(8), named.reload(8),
	     named-checkconf(8), named-checkzone(8), rndc(8), and
	     rndc-confgen(8).

     WITH_BIND_SIGCHASE
	     Set to enable DNSSEC validation support for dig, host, and
	     nslookup.

     WITHOUT_BIND_UTILS
	     Set to avoid building or installing the BIND userland utilities,
	     dig(1), host(1), nslookup(1), and nsupdate(8).

     WITH_BIND_XML
	     Set to enable the http statistics interface for named.  This
	     requires ports/textproc/libxml2 to be installed in /usr/local.

     WITHOUT_BLUETOOTH
	     Set to not build Bluetooth related kernel modules, programs and
	     libraries.

     WITHOUT_BOOT
	     Set to not build the boot blocks and loader.

     WITHOUT_BSD_CPIO
	     Set to not build the BSD licensed version of cpio based on
	     libarchive(3).

     WITHOUT_BSNMP
	     Set to not build or install bsnmpd(1) and related libraries and
	     data files.

     WITHOUT_BZIP2
	     Set to not build contributed bzip2 software as a part of the base
	     system.  The option has no effect yet.  When set, it also
	     enforces the following options:

	     WITHOUT_BZIP2_SUPPORT

     WITHOUT_BZIP2_SUPPORT
	     Set to build some programs without optional bzip2 support.

     WITHOUT_CALENDAR
	     Set to not build calendar(1).

     WITHOUT_CDDL
	     Set to not build code licensed under Sun's CDDL.  When set, it
	     also enforces the following options:

	     WITHOUT_ZFS

     WITHOUT_CPP
	     Set to not build cpp(1).

     WITHOUT_CRYPT
	     Set to not build any crypto code.	When set, it also enforces the
	     following options:

	     WITHOUT_GSSAPI (can be overridden with WITH_GSSAPI)
	     WITHOUT_KERBEROS
	     WITHOUT_KERBEROS_SUPPORT
	     WITHOUT_OPENSSH
	     WITHOUT_OPENSSL

     WITHOUT_CTM
	     Set to not build ctm(1) and related utilities.

     WITHOUT_CVS
	     Set to not build CVS.

     WITHOUT_CXX
	     Set to not build g++(1) and related libraries.

     WITHOUT_DICT
	     Set to not build the Webster dictionary files.

     WITHOUT_DYNAMICROOT
	     Set this if you do not want to link /bin and /sbin dynamically.

     WITHOUT_EXAMPLES
	     Set to avoid installing examples to /usr/share/examples/.

     WITHOUT_FLOPPY
	     Set to not build or install programs for operating floppy disk
	     driver.

     WITHOUT_FORTH
	     Set to build bootloaders without Forth support.

     WITHOUT_FP_LIBC
	     Set to build libc without floating-point support.

     WITHOUT_FREEBSD_UPDATE
	     Set to not build freebsd-update(8).

     WITHOUT_GAMES
	     Set to not build games.

     WITHOUT_GCOV
	     Set to not build the gcov(1) tool.

     WITHOUT_GDB
	     Set to not build gdb(1).

     WITHOUT_GNU
	     Set to not build contributed GNU software as a part of the base
	     system.  This option can be useful if the system built must not
	     contain any code covered by the GNU Public License due to legal
	     reasons.  The option has no effect yet.  When set, it also
	     enforces the following options:

	     WITHOUT_GNU_SUPPORT

     WITHOUT_GNU_GREP
	     Set to not build GNU grep as a part of the base system.

     WITHOUT_GNU_SUPPORT
	     Set to build some programs without optional GNU support.

     WITHOUT_GPIB
	     Set to not build GPIB bus support.

     WITHOUT_GROFF
	     Set to not build groff(1).

     WITHOUT_GSSAPI
	     Set to not build libgssapi.

     WITH_HESIOD
	     Set to build Hesiod support.

     WITHOUT_HTML
	     Set to not build HTML docs.

     WITH_IDEA
	     Set to build the IDEA encryption code.  This code is patented in
	     the USA and many European countries.  It is YOUR RESPONSIBILITY
	     to determine if you can legally use IDEA.

     WITHOUT_INET6
	     Set to not build programs and libraries related to IPv6 network‐
	     ing.  When set, it also enforces the following options:

	     WITHOUT_INET6_SUPPORT

     WITHOUT_INET6_SUPPORT
	     Set to build libraries, programs, and kernel modules without IPv6
	     support.

     WITHOUT_INFO
	     Set to not make or install info(5) files.

     WITHOUT_INSTALLLIB
	     Set this if you do not want to install optional libraries.	 For
	     example when creating a nanobsd(8) image.

     WITHOUT_IPFILTER
	     Set to not build IP Filter package.

     WITHOUT_IPFW
	     Set to not build IPFW tools.

     WITHOUT_IPX
	     Set to not build programs and libraries related to IPX network‐
	     ing.  When set, it also enforces the following options:

	     WITHOUT_IPX_SUPPORT
	     WITHOUT_NCP

     WITHOUT_IPX_SUPPORT
	     Set to build some programs without IPX support.

     WITHOUT_JAIL
	     Set to not build tools for the support of jails; e.g.  jail(8).

     WITHOUT_KERBEROS
	     Set this if you do not want to build Kerberos 5 (KTH Heimdal).
	     When set, it also enforces the following options:

	     WITHOUT_GSSAPI (can be overridden with WITH_GSSAPI)
	     WITHOUT_KERBEROS_SUPPORT

     WITHOUT_KERBEROS_SUPPORT
	     Set to build some programs without Kerberos support, like cvs(1),
	     ssh(1), telnet(1), sshd(8), and telnetd(8).

     WITHOUT_KVM
	     Set to not build the libkvm library as a part of the base system.
	     The option has no effect yet.  When set, it also enforces the
	     following options:

	     WITHOUT_KVM_SUPPORT

     WITHOUT_KVM_SUPPORT
	     Set to build some programs without optional libkvm support.

     WITHOUT_LEGACY_CONSOLE
	     Set to not build programs that support a legacy PC console; e.g.
	     kbdcontrol(8) and vidcontrol(8).

     WITHOUT_LIB32
	     On amd64, set to not build 32-bit library set and a ld-elf32.so.1
	     runtime linker.

     WITHOUT_LIBPTHREAD
	     Set to not build the libpthread providing library, libthr.	 When
	     set, it also enforces the following options:

	     WITHOUT_BIND
	     WITHOUT_BIND_DNSSEC
	     WITHOUT_BIND_ETC
	     WITHOUT_BIND_LIBS_LWRES
	     WITHOUT_BIND_MTREE
	     WITHOUT_BIND_NAMED
	     WITHOUT_BIND_UTILS
	     WITHOUT_LIBTHR

     WITHOUT_LIBTHR
	     Set to not build the libthr (1:1 threading) library.  When set,
	     it also enforces the following options:

	     WITHOUT_BIND
	     WITHOUT_BIND_DNSSEC
	     WITHOUT_BIND_ETC
	     WITHOUT_BIND_LIBS_LWRES
	     WITHOUT_BIND_MTREE
	     WITHOUT_BIND_NAMED
	     WITHOUT_BIND_UTILS

     WITHOUT_LOCALES
	     Set to not build localization files; see locale(1).

     WITHOUT_LOCATE
	     Set to not build locate(1) and related programs.

     WITHOUT_LPR
	     Set to not build lpr(1) and related programs.

     WITHOUT_MAIL
	     Set to not build any mail support (MUA or MTA).  When set, it
	     also enforces the following options:

	     WITHOUT_MAILWRAPPER
	     WITHOUT_SENDMAIL

     WITHOUT_MAILWRAPPER
	     Set to not build the mailwrapper(8) MTA selector.

     WITHOUT_MAKE
	     Set to not install make(1) and related support files.

     WITHOUT_MAN
	     Set to not build manual pages.  When set, it also enforces the
	     following options:

	     WITHOUT_MAN_UTILS (can be overridden with WITH_MAN_UTILS)

     WITHOUT_MAN_UTILS
	     Set to not build utilities for manual pages, apropos(1),
	     catman(1), makewhatis(1), man(1), whatis(1), manctl(8), and
	     related support files.

     WITHOUT_NCP
	     Set to not build programs, libraries, and kernel modules related
	     to NetWare Core protocol.

     WITHOUT_NDIS
	     Set to not build programs and libraries related to NDIS emulation
	     support.

     WITHOUT_NETCAT
	     Set to not build nc(1) utility.

     WITHOUT_NETGRAPH
	     Set to not build applications to support netgraph(4).  When set,
	     it also enforces the following options:

	     WITHOUT_ATM
	     WITHOUT_BLUETOOTH
	     WITHOUT_NETGRAPH_SUPPORT

     WITHOUT_NETGRAPH_SUPPORT
	     Set to build libraries, programs, and kernel modules without net‐
	     graph support.

     WITHOUT_NIS
	     Set to not build NIS(8) support and related programs.  If set,
	     you might need to adopt your nsswitch.conf(5) and remove ‘nis’
	     entries.

     WITHOUT_NLS
	     Set to not build NLS catalogs.

     WITHOUT_NLS_CATALOGS
	     Set to not build NLS catalog support for csh(1).

     WITHOUT_NS_CACHING
	     Set to disable name caching in the nsswitch subsystem.  The
	     generic caching daemon, nscd(8), will not be built either if this
	     option is set.

     WITHOUT_NTP
	     Set to not build ntpd(8) and related programs.

     WITHOUT_OBJC
	     Set to not build Objective C support.

     WITHOUT_OPENSSH
	     Set to not build OpenSSH.

     WITHOUT_OPENSSL
	     Set to not build OpenSSL.	When set, it also enforces the follow‐
	     ing options:

	     WITHOUT_GSSAPI (can be overridden with WITH_GSSAPI)
	     WITHOUT_KERBEROS
	     WITHOUT_KERBEROS_SUPPORT
	     WITHOUT_OPENSSH

     WITHOUT_PAM
	     Set to not build PAM library and modules.	This option is depre‐
	     cated and does nothing.  When set, it also enforces the following
	     options:

	     WITHOUT_PAM_SUPPORT

     WITHOUT_PAM_SUPPORT
	     Set to build some programs without PAM support, particularly
	     ftpd(8) and ppp(8).

     WITHOUT_PF
	     Set to not build PF firewall package.  When set, it also enforces
	     the following options:

	     WITHOUT_AUTHPF

     WITHOUT_PKGTOOLS
	     Set to not build pkg_add(8) and related programs.

     WITHOUT_PMC
	     Set to not build pmccontrol(8) and related programs.

     WITHOUT_PORTSNAP
	     Set to not build or install portsnap(8) and related files.

     WITHOUT_PPP
	     Set to not build ppp(8) and related programs.

     WITHOUT_PROFILE
	     Set to avoid compiling profiled libraries.

     WITHOUT_QUOTAS
	     Set to not build quota(8) and related programs.

     WITHOUT_RCMDS
	     Disable building of the BSD r-commands.  This includes rlogin(1),
	     rsh(1), etc.

     WITHOUT_RCS
	     Set to not build rcs(1) and related utilities.

     WITHOUT_RESCUE
	     Set to not build rescue(8).

     WITHOUT_ROUTED
	     Set to not build routed(8) utility.

     WITHOUT_SENDMAIL
	     Set to not build sendmail(8) and related programs.

     WITHOUT_SETUID_LOGIN
	     Set this to disable the installation of login(1) as a set-user-ID
	     root program.

     WITHOUT_SHAREDOCS
	     Set to not build the 4.4BSD legacy docs.

     WITHOUT_SSP
	     Set to not build world with propolice stack smashing protection.

     WITHOUT_SYMVER
	     Set to disable symbol versioning when building shared libraries.

     WITHOUT_SYSCONS
	     Set to not build syscons(4) support files such as keyboard maps,
	     fonts, and screen output maps.

     WITHOUT_SYSINSTALL
	     Set to not build sysinstall(8) and related programs.

     WITHOUT_TCSH
	     Set to not build and install /bin/csh (which is tcsh(1)).

     WITHOUT_TELNET
	     Set to not build telnet(8) and related programs.

     WITHOUT_TEXTPROC
	     Set to not build programs used for text processing.  When set, it
	     also enforces the following options:

	     WITHOUT_GROFF

     WITHOUT_TOOLCHAIN
	     Set to not install programs used for program development, compil‐
	     ers, debuggers etc.  The option does not work for build targets.
	     When set, it also enforces the following options:

	     WITHOUT_GDB

     WITHOUT_USB
	     Set to not build USB-related programs and libraries.

     WITHOUT_WIRELESS
	     Set to not build programs used for 802.11 wireless networks;
	     especially wpa_supplicant(8) and hostapd(8).  When set, it also
	     enforces the following options:

	     WITHOUT_WIRELESS_SUPPORT

     WITHOUT_WIRELESS_SUPPORT
	     Set to build libraries, programs, and kernel modules without
	     802.11 wireless support.

     WITHOUT_WPA_SUPPLICANT_EAPOL
	     Build wpa_supplicant(8) without support for the IEEE 802.1X pro‐
	     tocol and without support for EAP-PEAP, EAP-TLS, EAP-LEAP, and
	     EAP-TTLS protocols (usable only via 802.1X).

     WITHOUT_ZFS
	     Set to not build ZFS file system.

     WITHOUT_ZONEINFO
	     Set to not build the timezone database

FILES
     /etc/src.conf
     /usr/share/mk/bsd.own.mk

SEE ALSO
     make(1), make.conf(5), build(7), ports(7)

HISTORY
     The src.conf file appeared in FreeBSD 7.0.

AUTHORS
     This manual page was autogenerated.

BSD				 May 25, 2010				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net