stack_copy man page on FreeBSD

Printed from http://www.polarhome.com/service/man/?qf=stack_copy&af=0&tf=2&of=FreeBSD

STACK(9)		 BSD Kernel Developer's Manual		      STACK(9)

NAME
     stack — kernel thread stack tracing routines

SYNOPSIS
     #include <sys/param.h>
     #include <sys/stack.h>
     In the kernel configuration file:
     options DDB
     options STACK

     struct stack *
     stack_create(void);

     void
     stack_destroy(struct stack *st);

     int
     stack_put(struct stack *st, vm_offset_t pc);

     void
     stack_copy(struct stack *src, struct stack dst);

     void
     stack_zero(struct stack *st);

     void
     stack_print(struct stack *st);

     void
     stack_print_ddb(struct stack *st);

     void
     stack_print_short(struct stack *st);

     void
     stack_print_short_ddb(struct stack *st);

     void
     stack_sbuf_print(struct sbuf sb*, struct stack *st);

     void
     stack_sbuf_print_ddb(struct sbuf sb*, struct stack *st);

     void
     stack_save(struct stack *st);

DESCRIPTION
     The stack KPI allows querying of kernel stack trace information and the
     automated generation of kernel stack trace strings for the purposes of
     debugging and tracing.  To use the KPI, at least one of options DDB and
     options STACK must be compiled into the kernel.

     Each stack trace is described by a struct stack.  Before a trace may be
     created or otherwise manipulated, storage for the trace must be allocated
     with stack_create(), which may sleep.  Memory associated with a trace is
     freed by calling stack_destroy().

     A trace of the current kernel thread's call stack may be captured using
     stack_save().

     stack_print() and stack_print_short() may be used to print a stack trace
     using the kernel printf(9), and may sleep as a result of acquiring sx(9)
     locks in the kernel linker while looking up symbol names.	In locking-
     sensitive environments, the unsynchronized stack_print_ddb() and
     stack_print_short_ddb() variants may be invoked.  This function bypasses
     kernel linker locking, making it usable in ddb(4), but not in a live sys‐
     tem where linker data structures may change.

     stack_sbuf_print() may be used to construct a human-readable string,
     including conversion (where possible) from a simple kernel instruction
     pointer to a named symbol and offset.  The argument sb must be an ini‐
     tialized struct sbuf as described in sbuf(9).  This function may sleep if
     an auto-extending struct sbuf is used, or due to kernel linker locking.
     In locking-sensitive environments, such as ddb(4), the unsynchronized
     stack_sbuf_print_ddb() variant may be invoked to avoid kernel linker
     locking; it should be used with a fixed-length sbuf.

     The utility functions stack_zero, stack_copy, and stack_put may be used
     to manipulate stack data structures directly.

SEE ALSO
     ddb(4), printf(9), sbuf(9), sx(9)

AUTHORS
     The stack(9) function suite was created by Antoine Brodin.	 stack(9) was
     extended by Robert Watson for general-purpose use outside of ddb(4).

BSD				 June 24, 2009				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net