statvfs man page on Minix

Man page or keyword search:  
man Server   6208 pages
apropos Keyword Search (all sections)
Output format
Minix logo
[printable version]

STATVFS(5)		    BSD File Formats Manual		    STATVFS(5)

NAME
     statvfs — file system statistics

SYNOPSIS
     #include <sys/types.h>
     #include <sys/statvfs.h>

DESCRIPTION
     The ⟨sys/statvfs.h⟩ header defines the structures and functions that
     return information about a mounted file system.  The statvfs structure is
     defined as follows:

     struct statvfs {
	     unsigned long   f_bsize;  /* system block size */
	     unsigned long   f_frsize; /* system fragment size */

	     fsblkcnt_t	     f_blocks; /* number of blocks in file system */
	     fsblkcnt_t	     f_bfree;  /* free blocks avail in file system */
	     fsblkcnt_t	     f_bavail; /* free blocks avail to non-root */

	     fsfilcnt_t	     f_files;  /* total file nodes in file system */
	     fsfilcnt_t	     f_ffree;  /* free file nodes in file system */
	     fsfilcnt_t	     f_favail; /* free file nodes avail to non-root */

	     unsigned long   f_fsid;   /* File system ID */

	     unsigned long   f_flag;   /* flags */

	     unsigned long   f_namemax;/* maximum filename length */
     };

     The f_flag argument can have the following bits set:

     ST_RDONLY	     The filesystem is mounted read-only; Even the super-user
		     may not write on it.

     ST_NOSUID	     Setuid and setgid bits on files are not honored when they
		     are executed.

     ST_NOTRUNC	     File names longer than NAME_MAX are not truncated.

SEE ALSO
     statvfs(2)

HISTORY
     The ⟨sys/statvfs.h⟩ header first appeared in NetBSD 3.0.

BSD				 June 23, 2008				   BSD
[top]

List of man pages available for Minix

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net