subyte man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

STORE(9)		 BSD Kernel Developer's Manual		      STORE(9)

NAME
     store, casuword, subyte, susword, suword — store data to user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/time.h>
     #include <sys/systm.h>
     #include <sys/resourcevar.h>

     u_long
     casuword(u_long *base, u_long oldval, u_long newval);

     int
     subyte(void *base, int byte);

     int
     susword(void *base, int word);

     int
     suword(void *base, long word);

DESCRIPTION
     The store functions are designed to copy small amounts of data to user-
     space.

     The store routines provide the following functionality:

     casuword()	 Compares oldval with the word at base, and if equal, base is
		 set to newval.	 The old value at base is then returned.

     subyte()	 Stores a byte of data to the user-space address base.

     susword()	 Stores a short word of data to the user-space address base.

     suword()	 Stores a word of data to the user-space address base.

RETURN VALUES
     The store functions return 0 on success or -1 on failure.

SEE ALSO
     copy(9), fetch(9)

BSD				August 2, 2010				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net