TDFX(4) BSD Kernel Interfaces Manual TDFX(4)NAME
tdfx — Voodoo Graphics and VoodooII Memory Access GLIDE device driver
This driver creates an entry in /dev that allows programs (mostly
GLIDE-based software) to access the device memory of the Voodoo Graphics
and VoodooII 3D accelerators created by 3Dfx, Inc. This provides an
interface for applications based on the GLIDE API or that simply use the
API provided by the linux /dev/3dfx device to use the video device.
Supports all cards based on the following chipsets:
3Dfx Voodoo Graphics
3Dfx Voodoo II
Specifically, the following cards should work:
Diamond Multimedia Monster 3D
Diamond Multimedia Monster 3D II
Note that this driver does not currently have support for the Voodoo Ban‐
shee, Voodoo3, Voodoo5, or Voodoo6 based cards. It also does not cur‐
rently support the Voodoo Rush. It also does not yet handle the SLI fea‐
ture of the Voodoo II boards. You can only use each of them separately.
By including tdfx_linux, you can enable the linux ioctl code for this
driver, where the only supported applications currently reside.
/dev/3dfx Symlinked to default 3dfx board
/dev/3dfx* Character Device programming interface
/dev/voodoo Mirrors of above interfaces
/dev/voodoo* (Some apps use /dev/voodoo)
The tdfx driver appeared in FreeBSD 5.0, and was originally developed for
Linux kernel 2.0.x, later written for 2.2.x and 2.4.x.
The driver was developed by Coleman Kane ⟨firstname.lastname@example.org⟩ after the
linux version of this driver by Darryll Straus, John Taylor, Jens Axboe,
Carlo Wood ⟨email@example.com⟩ and Joseph Kain ⟨firstname.lastname@example.org⟩ to be
directly compatible with it and support the many GLIDE based games avail‐
able for Linux and UNIX.
BSD February 19, 2001 BSD