TMPFS(5) BSD File Formats Manual TMPFS(5)NAMEtmpfs — efficient memory file system
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The tmpfs driver will permit the FreeBSD kernel to access tmpfs file sys‐
The following options are available when mounting tmpfs file systems:
gid root group id.
uid root user id.
mode permissions in octal format.
inodes maximum number of inodes.
size maximum size (in bytes) for the file system.
To mount a tmpfs memory file system:
mount -ttmpfs tmpfs /tmp
SEE ALSOnmount(2), unmount(2), fstab(5), mount(8)HISTORY
The tmpfs driver first appeared in FreeBSD 7.0.
The tmpfs kernel implementation was written by Julio M. Merino Vidal
⟨jmmv@NetBSD.org⟩ as a Google SoC project.
Rohit Jalan and others ported it from NetBSD to FreeBSD.
This manual page was written by Xin LI ⟨delphij@FreeBSD.org⟩.
The tmpfs kernel implementation is currently considered as an experimen‐
tal feature. Some file system mount time options are not well supported.
BSD June 12, 2008 BSD