TZSETUP(8) BSD System Manager's Manual TZSETUP(8)NAMEtzsetup — set local timezone
SYNOPSIStzsetup [-ns] [default]
The tzsetup utility reads a database of timezone information and presents
a menu allowing the user to select a specific zone without knowing the
details of the database layout. The selected zone is installed as the
system default zone. The tzsetup utility also determines whether any
adjustment is necessary for systems where the hardware clock does not
The following option is available:
-n Do not create or copy files.
-s Skip the initial question about adjusting the clock if
not set to UTC.
It is possible to short-circuit the menu system by specifying a default
on the command line; this is intended mainly for pre-configured installa‐
The contents of the timezone database are indexed by
/usr/share/zoneinfo/zone.tab. This file lists, for each timezone data
file, the ISO 3166 territory code, approximate geographical coordinates
(in ISO 6709 format), and location within the territory.
The maintainers of the database maintain the following policies:
1. At least one zone for every country or inhabited geographical
2. One zone for every distinct, documented timezone history since
the beginning of the UNIX epoch (January 1, 1970, GMT).
3. Each zone is named for the most populous city therein. (Where
possible, the database includes pre-1970 history for its
The source code to the database (/usr/src/share/zoneinfo/[a-z]*) contains
many additional comments and documentation references for the histori‐
/etc/localtime current time zone file
/etc/wall_cmos_clock see adjkerntz(8).
/usr/share/misc/iso3166 mapping of ISO 3166 territory codes to
/usr/share/zoneinfo directory for zoneinfo files
/usr/share/zoneinfo/zone.tab mapping of timezone file to country and
SEE ALSOdate(1), adjtime(2), ctime(3), timezone(3), tzfile(5), adjkerntz(8),
The representation of certain localities as being associated with certain
countries and/or territories is for the purposes of identification only,
and does not imply any endorsement or rejection on the part of the
FreeBSD Project of the territorial claims of any entity.
Programs which are already running when tzsetup creates or updates
/etc/localtime will not reflect the updated timezone. When the system is
first configured for a non-UTC hardware clock, it is necessary to run
adjkerntz(8) (which normally happens as a part of system startup) in
order to update the kernel's idea of the correct timezone offset.
BSD July 4, 2009 BSD