uhid man page on MirBSD

Man page or keyword search:  
man Server   6113 pages
apropos Keyword Search (all sections)
Output format
MirBSD logo
[printable version]

UHID(4)			   BSD Programmer's Manual		       UHID(4)

NAME
     uhid - USB generic HID support

SYNOPSIS
     uhid* at uhidev? reportid ?

DESCRIPTION
     The uhid driver provides support for all HID (Human Interface Device) in-
     terfaces in USB devices that do not have a special driver.

     The device handles the following ioctl(2) calls:

     USB_GET_REPORT_ID (int)
	     Get the report identifier used by this HID report.

     USB_GET_REPORT_DESC (struct usb_ctl_report_desc)
	     Get the HID report descriptor. Using this descriptor the exact
	     layout and meaning of data to/from the device can be found. The
	     report descriptor is delivered without any processing.

	     struct usb_ctl_report_desc {
		 int	 size;
		 u_char	 data[1024]; /* filled data size will vary */
	     };

     USB_SET_IMMED (int)
	     Sets the device in a mode where each read(2) will return the
	     current value of the input report. Normally a read(2) will only
	     return the data that the device reports on its interrupt pipe.
	     This call may fail if the device does not support this feature.

     USB_GET_REPORT (struct usb_ctl_report)
	     Get a report from the device without waiting for data on the in-
	     terrupt pipe. The report field indicates which report is request-
	     ed. It should be UHID_INPUT_REPORT, UHID_OUTPUT_REPORT, or
	     UHID_FEATURE_REPORT. This call may fail if the device does not
	     support this feature.

	     struct usb_ctl_report {
		     int report;
		     u_char  data[1024];     /* used data size will vary */
	     };

     USB_SET_REPORT (struct usb_ctl_report)
	     Set a report in the device. The report field indicates which re-
	     port is to be set. It should be UHID_INPUT_REPORT,
	     UHID_OUTPUT_REPORT, or UHID_FEATURE_REPORT. This call may fail if
	     the device does not support this feature.

     Use read(2) to get data from the device. Data should be read in chunks of
     the size prescribed by the report descriptor.

     Use write(2) send data to the device. Data should be written in chunks of
     the size prescribed by the report descriptor.

SEE ALSO
     usbhidctl(1), usbhid(3), intro(4), uhidev(4), usb(4)

HISTORY
     The uhid driver appeared in OpenBSD 2.6.

MirOS BSD #10-current		July 12, 1998				     1
[top]

List of man pages available for MirBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net