vm_fault_prefault man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_FAULT_PREFAULT(9)	 BSD Kernel Developer's Manual	  VM_FAULT_PREFAULT(9)

NAME
     vm_fault_prefault — cluster page faults into a process's address space

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/pmap.h>

     void
     vm_fault_prefault(pmap_t pmap, vm_offset_t addra, vm_map_entry_t entry);

DESCRIPTION
     The vm_fault_prefault() function provides a means of clustering page‐
     faults into a process's address space.  It operates upon the physical map
     pmap.  The entry argument specifies the entry to be prefaulted; the addra
     argument specifies the beginning of the mapping in the process's virtual
     address space.

     It is typically called by vm_fault() after the first page fault.  It ben‐
     efits the execve(2) system call by eliminating repetitive calls to
     vm_fault(), which would otherwise be made to bring the process's exe‐
     cutable pages into physical memory.

IMPLEMENTATION NOTES
     This is a machine-independent function which calls the machine-dependent
     pmap_is_prefaultable(9) helper function to determine if a page may be
     prefaulted into physical memory.

SEE ALSO
     execve(2), pmap_is_prefaultable(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 21, 2003				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net