vslock man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VSLOCK(9)		 BSD Kernel Developer's Manual		     VSLOCK(9)

NAME
     vslock, vsunlock — lock/unlock user space addresses in memory

SYNOPSIS
     #include <sys/param.h>
     #include <sys/proc.h>
     #include <vm/vm.h>
     #include <vm/vm_extern.h>

     int
     vslock(void *addr, size_t len);

     void
     vsunlock(void *addr, size_t len);

DESCRIPTION
     The vslock() and vsunlock() functions respectively lock and unlock a
     range of addresses belonging to the currently running process into mem‐
     ory.  The actual amount of memory locked is a multiple of the machine's
     page size.	 The starting page number is computed by truncating addr to
     the nearest preceding page boundary, and by rounding up addr + len to the
     next page boundary.  The process context to use for this operation is
     taken from the global variable curproc.

RETURN VALUES
     The vslock() function will return 0 on success, otherwise it will return
     one of the errors listed below.

ERRORS
     The vslock() function will fail if:

     [EINVAL]		The addr and len parameters specify a memory range
			that wraps around the end of the machine address
			space.

     [ENOMEM]		The size of the specified address range exceeds the
			system limit on locked memory.

     [ENOMEM]		Locking the requested address range would cause the
			process to exceed its per-process locked memory limit.

     [EFAULT]		Some portion of the indicated address range is not
			allocated.  There was an error faulting/mapping a
			page.

BSD				August 10, 2004				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net