WLAN_TKIP(4) BSD Kernel Interfaces Manual WLAN_TKIP(4)NAMEwlan_tkip — TKIP and Michael crypto support for 802.11 devices
The wlan_tkip module handles the TKIP and Michael cryptographic require‐
ments of the WPA and 802.11i protocols. It does encapsulation and decap‐
sulation of TKIP-encoded 802.11 frames and optionally calculates the TKIP
cipher and Michael MIC. The wlan_tkip module is an 802.11 cryptographic
plugin module for use by the wlan(4) module. This module is automati‐
cally loaded if a TKIP key is configured; typically by a WPA supplicant
program such as wpa_supplicant, or a WPA authenticator program such as
hostapd. Should the underlying network device not be capable of doing
the TKIP and/or Michael calculations in hardware, the wlan_tkip module
will do the work.
SEE ALSOwlan(4), wlan_ccmp(4), wlan_wep(4)STANDARDS
More information can be found in the IEEE 802.11, WPA, and 802.11i Stan‐
The wlan_tkip driver first appeared in FreeBSD 6.0.
BSD December 7, 2004 BSD