ZX(4) OpenBSD Programmer's Manual (SPARC64) ZX(4)NAMEzx - accelerated 24-bit color frame buffer
zx* at sbus?
wsdisplay* at zx?
The ZX and TurboZX are dual-slot SBus color frame buffers, with graphics
acceleration and overlay capabilities. They are also known as the Sun
``Leo'' graphics card.
The zx driver interfaces the frame buffer with the wscons(4) console
framework. It does not provide direct device driver entry points but
makes its functions available via the internal wsdisplay(4) interface.
The following resolutions are supported by the ZX frame buffer:
Resolution Refresh Rate
1280x1024 76 Hz Non-interlaced
1280x1024 67 Hz Non-interlaced
1152x900 76 Hz Non-interlaced
1152x900 66 Hz Non-interlaced
1024x768 76 Hz Non-interlaced
1024x768 60 Hz Non-interlaced
960x680 112 Hz Stereo, non-interlaced
56 Hz field rate per eye
960x680 108 Hz Stereo, non-interlaced
54 Hz field rate per eye
770x575 50 Hz Interlaced - PAL
640x480 59.94 Hz Interlaced - NTSC
If the ZX frame buffer is connected to a monitor at boot time, it will
select its display resolution depending of the monitor `select code'
provided by the 13W3 connector. If the frame buffer is not connected to
a monitor, the default resolution of 1152x900, with a 66 Hz refresh rate,
will be selected. The selected resolutions are:
Monitor Resolution Refresh Monitor
sense code Rate Type
0 1024x768 76 Hz X449A
1 1152x900 66 Hz
2 1280x1024 76 Hz X248A, GDM-205S
3 1152x900 66 Hz GDM-1955A15, GDM-1604A15, CPD-1790
4 1280x1024 67 Hz GDM-20D10, GDM-1962
5 1152x900 66 Hz
6 1152x900 76 Hz GDM-1662B, 17SMM4
7 1152x900 66 Hz
SEE ALSOintro(4), sbus(4), wscons(4), wsdisplay(4)CAVEATS
There is currently no software interface to change the frame buffer
resolution at runtime.
OpenBSD 4.9 March 31, 2008 OpenBSD 4.9