Missing permissions on Debian

Support for services available to Shell account users.

Moderator: Moderators

Missing permissions on Debian

Postby papa » Mon May 10, 2010 8:45 pm

I'm attempting to compile the old BSD fortune cookie program on Debian. I've modified the Makefile to install into my home directory. I get the following error when I try to build the program:

Code: Select all
papa@debian:~/games/fortune/fortune$ make
gcc -O2 -DFORTDIR=\"/home/p/papa/games\" -o fortune -I../strfile \
      -I/usr/include/bsd fortune.c -lbsd
cc1: error: /usr/local/include/i486-linux-gnu: Permission denied
cc1: error: /usr/local/include: Permission denied
make: *** [fortune] Error 1


Sure enough, I don't have read permission for /usr/local (actually, no read permission for /home/0/private/LINK/local, which /usr/local links to). It seems like I should have permission to the include directory in order for the compiler to work. Can this problem be corrected, please?
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 149
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Re: Missing permissions on Debian

Postby zoli » Wed May 19, 2010 12:25 am

Hello,

thank you for turning my attention to that issue.
The problem is corrected.
Regards,
Z
---
Zoltan Arpadffy
zoli
Forum Admin
Forum Admin
 
Posts: 764
Joined: Mon Sep 30, 2002 1:27 am
Location: Stockholm, Sweden

Re: Missing permissions on Debian

Postby papa » Wed May 19, 2010 4:08 pm

Thanks for fixing this problem, and for installing clisp.

make now gets a bit further before it runs into problems that are my package's fault rather than Debian's configuration. In any case, I'm now more interested in playing with clisp than with tinkering with old C code.

By the way, have my applications for shell accounts on Alpha, Netbsd, and Redhat made it to you through the post yet?
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 149
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Re: Missing permissions on Debian

Postby zoli » Wed May 19, 2010 10:09 pm

Hello,

papa_debian wrote:have my applications for shell accounts on Alpha, Netbsd, and Redhat made it to you through the post yet?


Yes, I have already yesterday activated all your accounts... in fact that triggered me to spend few hours with polarhome issues.
Seems the e-mail has not got through :(
Regards,
Z
---
Zoltan Arpadffy
zoli
Forum Admin
Forum Admin
 
Posts: 764
Joined: Mon Sep 30, 2002 1:27 am
Location: Stockholm, Sweden

Re: Missing permissions on Debian

Postby papa » Thu May 20, 2010 3:06 am

zoli wrote:Yes, I have already yesterday activated all your accounts


Thanks for that. I did try to logon to one of the accounts last night on the off-chance that you'd done just that, but got an error. I probably just missed you by a few keystrokes. Now that I know they're activated I'll try again tonight.
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 149
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka


Return to Shell accounts

Who is online

Users browsing this forum: No registered users and 1 guest

cron