VOP_RECLAIM man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VOP_INACTIVE(9)		 BSD Kernel Developer's Manual	       VOP_INACTIVE(9)

NAME
     VOP_INACTIVE, VOP_RECLAIM — reclaim file system resources for a vnode

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     VOP_INACTIVE(struct vnode *vp, struct thread *td);

     int
     VOP_RECLAIM(struct vnode *vp, struct thread *td);

DESCRIPTION
     The arguments are:

     vp	 The vnode being reclaimed.

     VOP_INACTIVE() is called when the kernel is no longer using the vnode.
     This may be because the reference count reaches zero or it may be that
     the file system is being forcibly unmounted while there are open files.
     It can be used to reclaim space for ‘open but deleted’ files.

     VOP_RECLAIM() is called when a vnode is being reused for a different file
     system.  Any file system specific resources associated with the vnode
     should be freed.

LOCKS
     For VOP_INACTIVE, the vp will be locked on entry.	Your VOP_INACTIVE code
     must unlock the vp prior to returning.

     For VOP_RECLAIM, the vp will not be locked on entry and should be left
     unlocked on return.

SEE ALSO
     vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net