ACPI_AIBOOST(4) BSD Kernel Interfaces Manual ACPI_AIBOOST(4)NAMEacpi_aiboost — ASUS AI Booster hardware monitor
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The acpi_aiboost driver provides support for monitoring the hardware sen‐
sors in recent ASUS motherboards. The driver uses ACPI as the backend to
fetch sensor values and descriptions and provides its data via the
sysctl(8) interface, under dev.acpi_aiboost.0 namespace. Descriptions
for these values are available with sysctl -d.
The acpi_aiboost driver typically has 7 sensors, depending on the mother‐
board and chipset:
Sensor Units Typical Use
CPU uK CPU Temperature
MB uK MB Temperature
VCC uV DC Core Voltage
+3.3V uV DC +3.3 Voltage
+5V uV DC +5 Voltage
+12V uV DC +12 Voltage
CPU RPM CPU Fan
SEE ALSOacpi(4), sysctl.conf(5)sysctl(8)HISTORY
The acpi_aiboost driver first appeared in FreeBSD 7.0.
The acpi_aiboost driver was written by Takanori Watanabe. This manual
page was written by Juan Romero Pardines, who adapted the code for
NetBSD, and adopted back to FreeBSD by Takanori Watanabe.
It's possible to modify voltages via the ACPI methods in the DSDT, but
for now the driver only reports the sensors' values. CPU Q-Fan is
another thing that is typically specified in the ACPI namespace, and in
the future we should handle this feature (to enable or disable auto‐
matic/manual fan mode).
BSD March 14, 2007 BSD