ATH3KFW(8) BSD System Manager's Manual ATH3KFW(8)NAMEath3kfw — firmware download utility for Atheros AR3011 chip based Blue‐
tooth USB devices
SYNOPSISath3kfw-d device_name -f firmware_file_name
The ath3kfw utility downloads the specified firmware file to the speci‐
fied ugen(4) device.
This utility will only work with Atheros AR3011 chip based Bluetooth USB
devices. The identification is currently based on USB vendor ID/product
ID pair. The vendor ID should be 0x0cf3 (USB_VENDOR_ATHEROS2) and the
product ID should be 0x3000.
Firmware files ath3k-1.fw and ath3k-2.fw can be obtained from the linux-
The options are as follows:
Specify ugen(4) device name.
Specify firmware file name for download.
-h Display usage message and exit.
The ath3kfw utility exits 0 on success, and >0 if an error occurs.
SEE ALSOlibusb(3), ugen(4), devd(8)AUTHORS
Maksim Yevmenkin ⟨firstname.lastname@example.org⟩
Most likely. Please report if found.
BSD Novermber 9, 2010 BSD