BOOT(9) BSD Kernel Developer's Manual BOOT(9)NAMEboot — halt or reboot the system
The boot() function handles final system shutdown, and either halts or
reboots the system. The exact action to be taken is determined by the
flags passed in howto and by whether or not the system has finished auto‐
If the system has finished autoconfiguration, boot() does the following:
1. If this is the first invocation of boot() and the RB_NOSYNC
flag is not set in howto, syncs and unmounts the system disks
by calling vfs_unmountall(9).
2. Disables interrupts.
3. If rebooting after a crash (i.e., if RB_DUMP is set in howto,
but RB_HALT is not), saves a system crash dump.
4. Runs any shutdown hooks previously registered.
5. Prints a message indicating that the system is about to be
halted or rebooted.
6. If RB_HALT is set in howto, halts the system. Otherwise,
reboots the system.
If the system has not finished autoconfiguration, boot() runs any shut‐
down hooks previously registered, prints a message, and halts the system.
SEE ALSOvfs_unmountall(9)BSD February 14, 1997 BSD