BOOT.CONFIG(5) BSD File Formats Manual BOOT.CONFIG(5)NAMEboot.config — Configuration file for the boot blocks
The boot.config file contains options for the FreeBSD boot block code.
When the FreeBSD boot loader runs, it searches the “a” slice of the boot
partition for a boot.config file (as a result, slices which are missing
an “a” partition require user intervention during the boot process). If
the boot.config file is found, its contents are used as the default con‐
figuration options for the boot block code and are echoed to the system
A valid format of this file is to put BIOS drive number, a controller
type, a unit number, a partition, a kernel file name, and any other valid
boot(8) option on a single line, as it is done at the “boot:” prompt.
The options related to the boot image selection described below and all
the other options available for boot.config are documented in detail in
the boot(8) manual page.
# echo "-P" > /boot.config
will activate the serial console of FreeBSD.
# echo "1:ad(1,a)/boot/loader" > /boot.config
will instruct the second stage of boot(8) on the first disk to boot with
the third boot(8) stage from the second disk.
# echo "1:ad(1,a)/boot/loader -P" > /boot.config
will do both of the above.
/boot.config parameters for the boot blocks (optional)
SEE ALSOboot(8), loader(8)AUTHORS
This manual page was written by Daniel Gerzo ⟨danger@FreeBSD.org⟩.
BSD May 13, 2007 BSD