bpf man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

BPF(9)			 BSD Kernel Developer's Manual			BPF(9)

NAME
     bpf — Berkeley Packet Filter kernel interface

SYNOPSIS
     #include <sys/mbuf.h>
     #include <net/bpf.h>

DESCRIPTION
     bpf is called via an operations vector described by the following struct:

     struct bpf_ops {
	     void (*bpf_attach)(struct ifnet *, u_int, u_int, struct bpf_if **);
	     void (*bpf_detach)(struct ifnet *);
	     void (*bpf_change_type)(struct ifnet *, u_int, u_int);

	     void (*bpf_tap)(struct bpf_if *, u_char *, u_int);
	     void (*bpf_mtap)(struct bpf_if *, struct mbuf *);
	     void (*bpf_mtap2)(struct bpf_if *, void *, u_int, struct mbuf *);
	     void (*bpf_mtap_af)(struct bpf_if *, uint32_t, struct mbuf *);
	     void (*bpf_mtap_et)(struct bpf_if *, uint16_t, struct mbuf *);
	     void (*bpf_mtap_sl_in)(struct bpf_if *, u_char *, struct mbuf **);
	     void (*bpf_mtap_sl_out)(struct bpf_if *, u_char *, struct mbuf *);
     };

     This vector is found from struct bpf_ops * bpf_ops.  It is either a
     “stub” implementation or a real implementation, depending on whether bpf
     is absent or present in the kernel, respectively.

CODE REFERENCES
     The bpf implementation is located in sys/net/bpf.c, the stub implementa‐
     tion is in sys/net/bpf_stub.c, and sys/net/bpf.h describes the interface.

BSD				 June 8, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net