bus_release_resource man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

BUS_RELEASE_RESOURCE(9)	 BSD Kernel Developer's Manual BUS_RELEASE_RESOURCE(9)

NAME
     bus_release_resource — release resources on a bus

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     #include <machine/bus.h>
     #include <sys/rman.h>
     #include <machine/resource.h>

     int
     bus_release_resource(device_t dev, int type, int rid,
	 struct resource *r);

DESCRIPTION
     Free a resource allocated by bus_alloc_resource(9).  The resource must
     not be in use on release, i.e., call an appropriate function before (e.g.
     bus_teardown_intr(9) for IRQs).

     dev is the device that owns the resource.

     type is the type of resource that is released.  It must be of the same
     type you allocated it as before.  See bus_alloc_resource(9) for valid
     types.

     rid is the resource ID of the resource.  The rid value must be the same
     as the one returned by bus_alloc_resource(9).

     r is the pointer to struct res, i.e., the resource itself, returned by
     bus_alloc_resource(9).

RETURN VALUES
     EINVAL is returned, if the device dev has no parent, 0 otherwise.	The
     kernel will panic, if it cannot release the resource.

EXAMPLES
	     /* deactivate IRQ */
	     bus_teardown_intr(dev, foosoftc->irqres, foosoftc->irqid);

	     /* release IRQ resource */
	     bus_release_resource(dev, SYS_RES_IRQ, foosoftc->irqid,
		     foosoftc->irqres);

	     /* release I/O port resource */
	     bus_release_resource(dev, SYS_RES_IOPORT, foosoftc->portid,
		     foosoftc->portres);

SEE ALSO
     bus_alloc_resource(9), device(9), driver(9)

AUTHORS
     This manual page was written by Alexander Langer ⟨alex@big.endian.de⟩.

BSD				 May 18, 2000				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net