bus_set_resource man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

BUS_SET_RESOURCE(9)	 BSD Kernel Developer's Manual	   BUS_SET_RESOURCE(9)

NAME
     bus_set_resource — associate a definite resource with a given resource ID

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     #include <machine/bus.h>
     #include <sys/rman.h>
     #include <machine/resource.h>

     int
     bus_set_resource(device_t dev, int type, int rid, u_long start,
	 u_long count);

DESCRIPTION
     The bus_set_resource() function sets the start address of the resource
     type, rid pair to be count long.  Typically, client drivers do not use
     this interface.  Bus drivers, however, often use it to set up the
     resources a client driver uses.

     The arguments are as follows:

     dev     The device to set the resource on.

     type    The type of resource you want to allocate.	 It is one of:

	     SYS_RES_IRQ     for IRQs
	     SYS_RES_DRQ     for ISA DMA lines
	     SYS_RES_IOPORT  for I/O ports
	     SYS_RES_MEMORY  for I/O memory

     rid     A bus-specific handle that identifies the resource being allo‐
	     cated.

     start   The start address of this resource.

     count   The length of the resource.  For example, the size of the memory
	     in bytes.

RETURN VALUES
     Zero is returned on success, otherwise an error is returned.

SEE ALSO
     bus_alloc_resource(9), bus_get_resource(9), device(9), driver(9)

AUTHORS
     This manual page was written by Warner Losh ⟨imp@FreeBSD.org⟩.

BSD				March 29, 2003				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net