CHROOT(8) BSD System Manager's Manual CHROOT(8)NAMEchroot — change root directory
SYNOPSISchroot [-u -user] [-g -group] [-G -group,group,...] newroot [command]
The chroot utility changes its current and root directories to the sup‐
plied directory newroot and then exec's command, if supplied, or an
interactive copy of the user's login shell.
If the -u, -g or -G options are given, the user, group and group list of
the process are set to these values after the chroot has taken place.
See setgid(2), setgroups(2), setuid(2), getgrnam(3) and getpwnam(3).
Note, command or the shell are run as your real-user-id.
The following environment variable is referenced by :
SHELL If set, the string specified by SHELL is interpreted as the name
of the shell to exec. If the variable SHELL is not set, /bin/sh
SEE ALSOchdir(2), chroot(2), environ(7), jail(8)HISTORY
The chroot utility first appeared in 4.4BSD.
SECURITY CONSIDERATIONSchroot should never be installed setuid root, as it would then be possi‐
ble to exploit the program to gain root privileges.
BSD January 24, 2002 BSD