CONSCONTROL(8) BSD System Manager's Manual CONSCONTROL(8)NAMEconscontrol — control physical console devices
conscontrol mute on | off
conscontrol add | delete console
conscontrol set console | unset
The conscontrol utility is used to examine and modify the physical
devices which back the virtual console devices. If no arguments (or only
the list command) are specified, the current console settings are shown.
There are two types of logical consoles; a high level console which is
represented by /dev/console, and a low level console. The low level con‐
sole is used for kernel printf(9) and ddb(4) debugger support, while the
high level console is used by user programs like syslogd(8). Multiple
device support is implemented only for the low level console; the high
level console is set to the first device in the console list.
Multiple console support may be invoked by passing the kernel the -D flag
from the boot loader, or by using conscontrol to change the list of con‐
sole devices after the system has booted.
The following options are available:
add | delete console
Add or delete a physical device from the logical console. The
device must support low-level console operations. Adding a
device will place it at the front of the list of console devices;
the first device is used for the high level console.
The console argument is the name of a console device in /dev; the
name of the directory may be omitted.
mute on | off
Change the state of console muting. All console output is sup‐
pressed when console muting is on.
set console | unset
Set or unset the virtual console. When unset, output from the
system, such as the kernel printf(9), always goes out to the real
main console. When set, it goes to another. This is an inter‐
face to the tty ioctl TIOCCONS.
SEE ALSOsio(4), syscons(4), tty(4), boot(8), loader(8)HISTORY
The conscontrol utility first appeared in FreeBSD 5.0.
BSD October 23, 2001 BSD