ddi_iomin man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

ddi_iomin(9F)		 Kernel Functions for Drivers		 ddi_iomin(9F)

NAME
       ddi_iomin - find minimum alignment and transfer size for DMA

SYNOPSIS
       #include <sys/conf.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int ddi_iomin(dev_info_t *dip, int initial, int streaming);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI). This interface is obsolete.

PARAMETERS
       dip	       A pointer to the device's dev_info structure.

       initial	       The initial minimum DMAtransfer size in bytes. This may
		       be  zero	 or  an	 appropriate  dlim_minxfer  value  for
		       device's	       ddi_dma_lim	  structure	  (see
		       ddi_dma_lim_sparc(9S)  or  ddi_dma_lim_x86(9S)).	  This
		       value must be a power of two.

       streaming       This argument, if non-zero, indicates that the returned
		       value should be modified to account for streaming  mode
		       accesses	 (see  ddi_dma_req(9S)	for  a	discussion  of
		       streaming versus non-streaming access mode).

DESCRIPTION
       The ddi_iomin() function, finds out the minimum	DMAtransfer  size  for
       the  device  pointed  to	 by  dip. This provides a mechanism by which a
       driver can determine the effects of underlying caches as well as inter‐
       vening bus adapters on the granularity of a DMA transfer.

RETURN VALUES
       The  ddi_iomin()	 function returns the minimum DMAtransfer size for the
       calling device, or it returns zero, which means	that  you  cannot  get
       there from here.

CONTEXT
       This function can be called from user, interrupt, or kernel context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Obsolete			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       ddi_dma_devalign(9F),	    ddi_dma_setup(9F),	     ddi_dma_sync(9F),
       ddi_dma_lim_sparc(9S), ddi_dma_lim_x86(9S), ddi_dma_req(9S)

       Writing Device Drivers

SunOS 5.10			  04 Apr 2006			 ddi_iomin(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net